[solved]Upgraded from Win 8.1 to 10, SmartDVB not functional

General support questions (e.g. question about device support problems or general application features/workings).

[solved]Upgraded from Win 8.1 to 10, SmartDVB not functional

Postby mzso » Sun Jun 14, 2020 6:16 pm

Hi!

I upgraded today. At first I got the message that starting of the device failed. So guessing the driver was not W10 compatible I downloaded the latest Astrometa driver for W10.

But all I get is blankness and the program hanging often. At best the OSD appears briefly. I get no video/audio. No signal and quality bars.
I looked into the devices options.

Now what?

I have the latest public beta. Portable x64 version.
Last edited by mzso on Sun May 09, 2021 10:51 am, edited 1 time in total.
OS: Windows 8.1 x64
Filters: all LAV
Renderer: madVR.
mzso
 
Posts: 0
Joined: Sat Jun 23, 2018 11:03 pm

Re: Upgraded from Win 8.1 to 10, SmartDVB not functional anymore

Postby SmartDVB » Sun Jun 14, 2020 6:27 pm

good evening,

Astrometa DVB-T2 PLP tuning relies on some AMDVBT2.dll DLL, perhaps that needs updating besides the w10 drivers, would only be pertinent for PLP switching if i recall well.
I suppose the x64 build worked fine with w8.1 before the upgrade?

best regards
SmartDVB
Site Admin
 
Posts: 616
Joined: Sun Feb 01, 2009 5:18 am

Re: Upgraded from Win 8.1 to 10, SmartDVB not functional anymore

Postby mzso » Mon Jun 15, 2020 12:17 am

Hmmm. I made a mistake. I need DVB-C. I reinstalled the DVB-C driver, but it's the same way.
I get nothing.

Tried running registerfilters.bat, but that didn't change anything either. (What does it mean, when there's an x on "installed modules" icons?)

I think it may be a driver/tuner issue, but I have no idea what to do.
OS: Windows 8.1 x64
Filters: all LAV
Renderer: madVR.
mzso
 
Posts: 0
Joined: Sat Jun 23, 2018 11:03 pm

Re: Upgraded from Win 8.1 to 10, SmartDVB not functional anymore

Postby SmartDVB » Mon Jun 15, 2020 9:45 am

I think it may be a driver/tuner issue, but I have no idea what to do.


sounds like driver/module issue imcompatibilty for some reason. Did you also try bdas.dev perhaps? With bda.dev when you look at devfces/bda.log do you see any meaningful error messages or other graph building or tuning clues? You might also send/save an error report and send it to me or post it here\. You might also check bda.dev device settings and see if any settings might affect tuning (direct/standard tuning). Sounds like some bda graph issue, you might even try blihdscan.dev but i don't think that will work with DVB-C devices. I remember adding some DVB-T tuning capabiities there but probably not DVB-C since i;'ve never really been able to test there locally myself, here in the Netherlands this has always been settop box bound mostly, but by now it's getting rather obsolete compared to other distribution types we have here, still might be possible to see if it will tune astrometa DVB-C devices better in your case if at all, not sure about that. Never mind that x in the devices dialog, that's some legacy probably just indicates which module is being used at that moment (i always intended to overhaul these things at some point towards some better graphical/different interface perhaps but never really got around to doing such things so stuck to the basics).
SmartDVB
Site Admin
 
Posts: 616
Joined: Sun Feb 01, 2009 5:18 am

Re: Upgraded from Win 8.1 to 10, SmartDVB not functional anymore

Postby mzso » Mon Jun 15, 2020 11:57 am

Well, it looks like I had to use an older driver. The latest one doesn't work on 10.
OS: Windows 8.1 x64
Filters: all LAV
Renderer: madVR.
mzso
 
Posts: 0
Joined: Sat Jun 23, 2018 11:03 pm

Re: Upgraded from Win 8.1 to 10, SmartDVB not functional anymore

Postby SmartDVB » Tue Jun 16, 2020 11:13 am

Odd, i would never have thought of that initially since i would think new drivers would at least work well with w10
SmartDVB
Site Admin
 
Posts: 616
Joined: Sun Feb 01, 2009 5:18 am

Re: Upgraded from Win 8.1 to 10, SmartDVB not functional anymore

Postby mzso » Sun Jun 21, 2020 5:46 pm

SmartDVB wrote:Odd, i would never have thought of that initially since i would think new drivers would at least work well with w10

Apparently something's glitchy about it. Other's have complained that they had to revert to the older driver.
(Yet others have claimed that that the tuner only works on USB2.0 ports on W10 with that driver, though I didn't test this.)

Though as I'm writing this I notice another problem. Even though madVR shows deinterlacing is enabled it clearly doesn't work, by the look of the obscene amount of combing.
(A familiar problem, though I'm not sure if it happened with SDVB or progDVB a good while before, nor do I remember it was solved.)
OS: Windows 8.1 x64
Filters: all LAV
Renderer: madVR.
mzso
 
Posts: 0
Joined: Sat Jun 23, 2018 11:03 pm

Re: [solved]Upgraded from Win 8.1 to 10, SmartDVB not functional

Postby mzso » Sun May 09, 2021 10:59 am

The dvb-c [url]driver from 2017 (170427)[/url]didn't work for some reason but the 2016 (160614) version did.

The newest "Driver for Windows 10 64-bit" doesn't have a DVB-C variant at all. But with AstrometaSwitch, one can change it to DVB-C mode and it works best thereafter. Faster channel switching and startup.
OS: Windows 8.1 x64
Filters: all LAV
Renderer: madVR.
mzso
 
Posts: 0
Joined: Sat Jun 23, 2018 11:03 pm


Return to Support

Who is online

Users browsing this forum: No registered users and 1 guest