Error connecting smart filter to decoder video input...

General support questions (e.g. question about device support problems or general application features/workings).

Error connecting smart filter to decoder video input...

Postby kleinerChemiker » Tue Apr 15, 2014 7:25 pm

...0x8004022a (....


Hi, I have this error with most of the channels. OS is Win8.1. I had SmartDVB running on my system, but I reinstalled the OS and this time I get this error. Please tell me, if you need further information.

tia
MIK
kleinerChemiker
 
Posts: 0
Joined: Tue Apr 15, 2014 7:19 pm

Re: Error connecting smart filter to decoder video input...

Postby SmartDVB » Wed Apr 16, 2014 2:30 pm

What video decoder do you use? Try changing it to some known working decoder, LAV, FFDSHOW (both free downloads). It could be the default MS-DTV codec on your new windows 8.1 install is inoperable? (I've seen this happen before, no default DVD functionality). Does this happen for SD and HD ?
SmartDVB
Site Admin
 
Posts: 616
Joined: Sun Feb 01, 2009 5:18 am

Re: Error connecting smart filter to decoder video input...

Postby kleinerChemiker » Wed Apr 16, 2014 3:00 pm

Thanks for your help. I tested severel channels which have a SD and HD version. HD was working, SD not. I attached a pic with the used codecs, but I have no others. I cannot remember installing codes the last time, when it worked.
Attachments
decoders.png
decoders.png (25.59 KiB) Viewed 10707 times
kleinerChemiker
 
Posts: 0
Joined: Tue Apr 15, 2014 7:19 pm

Re: Error connecting smart filter to decoder video input...

Postby SmartDVB » Wed Apr 16, 2014 3:15 pm

Which version are we talking about btw? When you previously installed it was it on exactly the same 8.1 os?

ok, i'd suggest to remove the current SD decoder. With the delete option. And add it again with the add option you see on the connection dialog, by selecting the microsoft video decoder in the 'add' dialog and the connection dialog. It will only be removed/readded inside smartdvb the actual codec on the system will not be touched.

But i suspect this might not solve your problem, do you have SD video with some other application which uses the ms dtv codec for SD? Like i mentioned it could be that sometimes SD video simply is turned off for windows installs. You could try installing the LAV filters, which are very good, non intrusive and well tested, you won't create much registry problem/corruption if you just add those codecs (don't go installing some codec packs). Then you could verify if you have SD with LAV.
SmartDVB
Site Admin
 
Posts: 616
Joined: Sun Feb 01, 2009 5:18 am

Re: Error connecting smart filter to decoder video input...

Postby kleinerChemiker » Wed Apr 16, 2014 4:04 pm

More or less the same 8.1, but you know, Windows gets bloated after some time and I had some problems, so I reinstalled the os. I'm useing SmartDVB 3.5.10.

It's working now with the LAV filters, thanks. I'm useing only SmartDVB and VLC, so I had no problems yet since VLC has its own codecs.

Thanks :)
kleinerChemiker
 
Posts: 0
Joined: Tue Apr 15, 2014 7:19 pm

Re: Error connecting smart filter to decoder video input...

Postby SmartDVB » Wed Apr 16, 2014 7:43 pm

I agree with you on the windows bloating, that's why I suggest to just install the necessary filters like LAV and don't use those registry polluting codec packs. I've had totally corrupted codec setup with such things in the past..
SmartDVB
Site Admin
 
Posts: 616
Joined: Sun Feb 01, 2009 5:18 am

Re: Error connecting smart filter to decoder video input...

Postby DVB-S PL » Fri Apr 25, 2014 1:55 pm

A little bit late, but small tip - try to switch Video renderer from Video Mixing Renderer 9 (VMR9) to Enhanced Video Renderer (EVR), it should be there, it can be more stable as VMR9 is older renderer designed by Microsoft many years ago, EVR is much more up to date ;)
DVB-S PL
 
Posts: 16
Joined: Sun Oct 18, 2009 4:30 pm
Location: Poland

Re: Error connecting smart filter to decoder video input...

Postby sebus » Tue Sep 01, 2015 1:09 pm

Thanks, LAV filters are the only way (or the easiest way) to make it work in Windows 8.1

sebus
sebus
 
Posts: 0
Joined: Tue Sep 01, 2015 1:02 pm

Re: Error connecting smart filter to decoder video input...

Postby adolfainsley8 » Fri Apr 29, 2016 12:14 pm

SD video with some other application which uses the ms dtv codec for SD? Like i mentioned it could be that sometimes SD video simply is turned off for windows installs. You could try installing the LAV filters, which are very good, non intrusive and well tested, you won't create much registry problem/corruption if you just add those codecs (don't go installing some codec packs). Then you could verify if you have SD with LAV.
waleeed
adolfainsley8
 
Posts: 0
Joined: Fri Apr 29, 2016 12:09 pm


Return to Support

Who is online

Users browsing this forum: No registered users and 2 guests

cron