0.2.1 beta test 2 install

This is the place where beta releases of the application or modules are made available. Only download if you're willing to cooperate in resolving any problems

0.2.1 beta test 2 install

Postby SmartDVB » Sat Jan 22, 2011 5:15 pm

another quick update, please remove the previous 0.2.1 if installed otherwise the install will fail ofcourse (your settings should be preserved, although just in case make a backup of your smartdvb.db if your current channel/sat list is precious to you). Also would like to know if the install is okay for users using xp 64 bit.

http://www.smartdvb.net/smartdvb/download/smartdvb021test2.rar
--
v0.2.1 small bugfix release beta 2.
Fixed: installer issues when installing vs2005 redistributable sp1, reverted to the plain
non sp1 version as this seemed to cause some issues. Also should include a check now
if the redistributable is already installed. Just to prevent any issues remove the
previously installed redist if installed with 0.2.1 beta 1.
Fixed: scheduling through the epg failed for some users, hopefully fixed.

--
SmartDVB
Site Admin
 
Posts: 616
Joined: Sun Feb 01, 2009 5:18 am

Re: 0.2.1 beta test 2 install

Postby Frozen » Sat Jan 22, 2011 9:08 pm

Also should include a check now if the redistributable is already installed


There's no check for vs2005 redistributable, I have forced to download/install it again, unless installation process will be canceled
Scheduling through epg working fine now

SS HD2
WIN 7 64bit

Thanks Jack
Frozen
 
Posts: 37
Joined: Sun Jun 14, 2009 2:49 am

Re: 0.2.1 beta test 2 install

Postby SmartDVB » Sun Jan 23, 2011 12:03 am

was the previous redistributable installed by the first 0.2.1 beta? if so this was sp1 and maybe because of that the install reinstalled it? if you run the setup now again does it skip the redistributable install?
SmartDVB
Site Admin
 
Posts: 616
Joined: Sun Feb 01, 2009 5:18 am

Re: 0.2.1 beta test 2 install

Postby icur12 » Mon Jan 24, 2011 3:24 am

The epg scheduler is working now. I uninstalled test1, then installed just the msi file for test2, since I already had the 2005 redistrbutable, but not the sp1. The sp1 must have been the problem.

I notice that if I select mpeg instead of ts for recording type, there is no difference.

Also, using TSReader to load the recorded ts file, I see that all the channels in the current transponder are saved, instead of just the channel that I have selected.

Thanks for keeping up the work on this.
icur12
 
Posts: 12
Joined: Wed Jan 19, 2011 10:33 pm

Re: 0.2.1 beta test 2 install

Postby SmartDVB » Mon Jan 24, 2011 7:20 pm

where exactly does the recording not use mpg? I have tested this and it seems fine here. About the mpg recording, i made this a long time ago and it's not super stable on all channels, i always wanted to rebuild this one day but everything takes time :-) so prefer useing ts recording in any case...
SmartDVB
Site Admin
 
Posts: 616
Joined: Sun Feb 01, 2009 5:18 am

Re: 0.2.1 beta test 2 install

Postby icur12 » Mon Jan 24, 2011 10:27 pm

Concerning the mpg vs ts, when I let the recording finish until the end, it did use mpg, although the file wasn't usable. This is DN, so it may be different than fta. Anyway, it seems that when I did short tests, it stayed at ts when I selected mpg. I'll need to test this further.

When I said that all the other channels are saved in the transponder, I just meant that the PMTs are showing for all channels, which is something I don't normally see when recording a single channel using ts.

I am new to Smartdvb, and every app has its own way of doing things, so I'll need to do more testing.


EDIT:
I see the problem with the extra channels being saved. The ts file now has all the streams from every channel in the transponder. When I use a program like VLC or MPC to play it back, it will grab the 1st stream it finds. If the channel I selected to record is not the 1st one in the list, the file will be unplayable, unless I use TSReader in file mode, and then select the correct channel. That's not much fun

Another thing I found is that if I have the records folder open while recording, none of the files I record are visible until I change to another folder then back.
icur12
 
Posts: 12
Joined: Wed Jan 19, 2011 10:33 pm

Re: 0.2.1 beta test 2 install

Postby mirecek1965 » Thu Jan 27, 2011 8:21 pm

With this new version i still cannot tune any channels on any sattellite :-(
Receiver is Anysee E30 S2 PLUS.
mirecek1965
 
Posts: 4
Joined: Thu Dec 16, 2010 4:14 pm

Re: 0.2.1 beta test 2 install

Postby SmartDVB » Thu Jan 27, 2011 11:47 pm

@icur: i've looked at this concerning the ts recording and i think it's just the pat entries for all pmt tables you're seeing and not that all audio/video pid's are actually there with tsreader. Looked at some other apps ts records and these sometime don't even show anything here in tsreaderlite. So maybe you can just remove the pat recording and see if that works better for u? About mpeg recording, i need to rewrite this i think somewhat for na, as it also does not include ac3 recording at the moment, so that's also on my todo list (darn this list is getting bigger and bigger :-)...

@mirecek1965: i've looked at the log you sent me finally and i see something strange. It seems the device is being started twice? I see this line 'StartDevice() OK' twice in the log? Without stopping the device in between. Do you always see this in your bda.log? if so this is something odd. Dunno if you did an upgrade, try a clean install just to be sure you're not using old bda.dev.
SmartDVB
Site Admin
 
Posts: 616
Joined: Sun Feb 01, 2009 5:18 am

Re: 0.2.1 beta test 2 install

Postby icur12 » Fri Jan 28, 2011 2:00 am

It's actually that all the PMTs are there in the PAT, and they all have the video and audio pids. I should have mentioned that I already tried all combinations of PAT, PMT and ECM. Without PAT, no channels or data exists at all. Without PMT, the channel numbers are there, but without the pids.

Every TS file I have saved using MyTheatre, TSReader, DVBPlus, etc, all have the PAT, and only 1 PMT with the channel that I have selected to record.

You probably need to try this on a transponder that has a mix of open and scrambled channels, with the open channel not in the 1st position.

About mpeg recording, I don't really care too much about that. I was just trying things to test. I always save in TS
icur12
 
Posts: 12
Joined: Wed Jan 19, 2011 10:33 pm

sometimes not work

Postby dahaka » Fri Jan 28, 2011 3:12 pm

sometimes not work and had to close and re-open it again.
XP SP3
http://www.4shared.com/file/nlDdtGP9/02 ... _logs.html
Windows 10 1703 X64
Smart DVB 0.5.X.X
Tevii DVBS2-S662 - driver 5.1.9.2
driver 5.1.8.5(the best but not work @ windows 10)
dahaka
 
Posts: 10
Joined: Fri Jan 15, 2010 6:44 pm

Re: 0.2.1 beta test 2 install

Postby SmartDVB » Fri Jan 28, 2011 3:25 pm

@icur: okay i see. Does that mean that the other apps simply strip the pat down and generate one themself with only the actual ts streams included, i now simply copy the pat from the ts mux, but the actual pids for video/audio etc are only the ones for the selected channel (or the ones you specifically selected in the ts recording dialog)? Could try to do that although i never saw this as a problem testing here as the streams seemed to run ok like this (vlc, mediaplayer etc). I will note this.
@dahaka: you mean no crash but hadu doesn't work anymore? Does it show any processing (cat etc) going on, if not might be a filtering problem. Running any other plugins?
SmartDVB
Site Admin
 
Posts: 616
Joined: Sun Feb 01, 2009 5:18 am

Re: 0.2.1 beta test 2 install

Postby dahaka » Fri Jan 28, 2011 8:15 pm

The whole smart stop working and i'm not watching any scrambled channels for now ,processing sometimes zero.

Work good now for sometimes.
Windows 10 1703 X64
Smart DVB 0.5.X.X
Tevii DVBS2-S662 - driver 5.1.9.2
driver 5.1.8.5(the best but not work @ windows 10)
dahaka
 
Posts: 10
Joined: Fri Jan 15, 2010 6:44 pm

Re: 0.2.1 beta test 2 install

Postby icur12 » Fri Jan 28, 2011 10:57 pm

That's correct. Only 1 pmt containing the channel and pids selected for recording. The problem is that if a program like VLC finds a scrambled channel before a clear one, it will usually give up.

With dn, there will always only be one clear channel, and chances are it won't be the 1st one.

EDIT: I just looked at the PAT again, and all the pids for every channel in the transponder are included with the TS file generated. This is why there is a problem.

Also, when I select the option to bring up the TS record menu, only 1 set of pids is shown, and it looks like you search for the channel name, but the problem is that often there are several different channels with the same channel name. What happens is that the first set of pids is what shows up, and often that is not the one that is decoded.
icur12
 
Posts: 12
Joined: Wed Jan 19, 2011 10:33 pm

Re: 0.2.1 beta test 2 install

Postby dahaka » Sat Jan 29, 2011 12:47 am

Two crashes with logs.

First one while watching in full screen and back to ordinary mood.
second when starting again.
http://www.4shared.com/file/GDjGkxqR/logs.html

Suggestion:
Rewrite all again with Microsoft.Visual.Studio.2010 only ,i think it will fix all problems, I'm not a coder and not sure about that.
Windows 10 1703 X64
Smart DVB 0.5.X.X
Tevii DVBS2-S662 - driver 5.1.9.2
driver 5.1.8.5(the best but not work @ windows 10)
dahaka
 
Posts: 10
Joined: Fri Jan 15, 2010 6:44 pm

Re: 0.2.1 beta test 2 install

Postby dahaka » Sun Jan 30, 2011 10:23 am

Re-installing it again and its work good for now.
Windows 10 1703 X64
Smart DVB 0.5.X.X
Tevii DVBS2-S662 - driver 5.1.9.2
driver 5.1.8.5(the best but not work @ windows 10)
dahaka
 
Posts: 10
Joined: Fri Jan 15, 2010 6:44 pm

Re: 0.2.1 beta test 2 install

Postby dahaka » Sun Jan 30, 2011 12:19 pm

No plugs now and crashing again while watching.

new logs [url]http://www.4shared.com/file/SAcTkrsl/021_beta_test_2.html
[/url]

Edit:
i meant crashing not closing
Windows 10 1703 X64
Smart DVB 0.5.X.X
Tevii DVBS2-S662 - driver 5.1.9.2
driver 5.1.8.5(the best but not work @ windows 10)
dahaka
 
Posts: 10
Joined: Fri Jan 15, 2010 6:44 pm

Re: 0.2.1 beta test 2 install

Postby jim_dvb » Tue Feb 01, 2011 10:20 pm

I installed the beta to try out scheduled recording.

When the tuner is set to the channel it's scheduled to record, it works well (just on brief TS recordings so far), just like a "live" recording.

When a channel change is needed, the recording fails. Only the teletext streams are identified in the resulting file - no video or audio. Further, the file name is taken from the initial channel, not the one intended to record.
v0.2.1.0 Win7 64-bit
TBS QBox II with bda driver
jim_dvb
 
Posts: 4
Joined: Tue Feb 01, 2011 6:45 pm

Re: 0.2.1 beta test 2 install

Postby sendlinger » Tue Feb 01, 2011 10:43 pm

EPG-recording works fine with beta2. It did not work with 0.2.0.
sendlinger
 
Posts: 1
Joined: Tue Feb 01, 2011 12:43 pm

Re: 0.2.1 beta test 2 install

Postby icur12 » Wed Feb 02, 2011 2:38 am

jim_dvb wrote:I installed the beta to try out scheduled recording.

When the tuner is set to the channel it's scheduled to record, it works well (just on brief TS recordings so far), just like a "live" recording.

When a channel change is needed, the recording fails. Only the teletext streams are identified in the resulting file - no video or audio. Further, the file name is taken from the initial channel, not the one intended to record.


Yes, exactly what I have found, except that I have no teletext streams in NA, but it looks like maybe it's the encrypted DN epg. Anyway, as you say, if a channel change is needed when the scheduler tries to select, the data is bad and the wrong filename is used.
icur12
 
Posts: 12
Joined: Wed Jan 19, 2011 10:33 pm

Re: 0.2.1 beta test 2 install (Recording)

Postby jim_dvb » Wed Feb 02, 2011 1:49 pm

Further info - recording also fails when the PC has to "wake", even if left on same channel and the receiver is still indicating "lock" (though that could just be a status lamp turned on/off by the driver/application).

I did make a good HD scheduled recording of 1 hour after leaving the app tuned to the same channel.
v0.2.1.0 Win7 64-bit
TBS QBox II with bda driver
jim_dvb
 
Posts: 4
Joined: Tue Feb 01, 2011 6:45 pm

Re: 0.2.1 beta test 2 install

Postby SmartDVB » Wed Feb 02, 2011 3:43 pm

oh okay thanks for the info. Never looked into the waking issue, i can imagine one needs to do some specific things in such a case, although i have read somewhere that some cards can have issues with this, but i assume you don't have this wake issue with other programs on the same system?
The single channel scheduling issue is a naming problem, will be fixed in the next beta, for now if you don't use the 'guide' as name setting it should still work hopefully, although you won't have the nice guide name if available.....
SmartDVB
Site Admin
 
Posts: 616
Joined: Sun Feb 01, 2009 5:18 am

Re: 0.2.1 beta test 2 install

Postby jim_dvb » Thu Feb 03, 2011 12:13 am

The PC woke to record OK under AltDVB and WMC (using DVBLink's TV Source as a DiSEqC 1.2 controller). SmartDVB wakes but records the same teletext-only file as when it tries to record a different channel. I suggest there's a common re-tune issue, rather than one specific to waking. I checked the "always re-tune" option box but it made no difference.

When scheduling a recording, the program offers a choice at the end to "Exit" or "Shutdown". Why no "Suspend"?
v0.2.1.0 Win7 64-bit
TBS QBox II with bda driver
jim_dvb
 
Posts: 4
Joined: Tue Feb 01, 2011 6:45 pm

Re: 0.2.1 beta test 2 install

Postby Frozen » Thu Feb 03, 2011 6:07 pm

SmartDVB wrote:was the previous redistributable installed by the first 0.2.1 beta? if so this was sp1 and maybe because of that the install reinstalled it? if you run the setup now again does it skip the redistributable install?


It's okay now after the second installing
Frozen
 
Posts: 37
Joined: Sun Jun 14, 2009 2:49 am

Re: 0.2.1 beta test 2 install

Postby SmartDVB » Thu Feb 10, 2011 3:44 pm

@jim: i've adressed these issues. Also a suspend option has now been added to the scheduler as this was pretty simple to do.
SmartDVB
Site Admin
 
Posts: 616
Joined: Sun Feb 01, 2009 5:18 am

Re: 0.2.1 beta test 2 install

Postby DVB-S PL » Fri Feb 11, 2011 2:47 am

About mpg recording: SmartDVB cannot record to MPG channel "Czworka" from Hot Bird (11,642H). It always produce 4 bytes file. I tried to find any other channel with the same problem, but tested some other 16:9 channels (I thought that maybe 16:9 was a problem) and everything was fine ;) With TS "Czworka" is recorder correctly, so this is not big problem - just reporting :)

Maybe this is codec related? I use now Elecard MPEG2 Video Decoder on Windows 7 x64 for SD channels.

EDIT: Not codec related, checked with Microsoft DTV-DVD Video Decoder.
DVB-S PL
 
Posts: 16
Joined: Sun Oct 18, 2009 4:30 pm
Location: Poland

Re: 0.2.1 beta test 2 install

Postby SmartDVB » Fri Feb 11, 2011 2:10 pm

hi. Does that channel perhaps have ac3? Still need to update the mpeg code to correctly work with ac3 audio also, and no cannot be codec related ..
SmartDVB
Site Admin
 
Posts: 616
Joined: Sun Feb 01, 2009 5:18 am

Re: 0.2.1 beta test 2 install

Postby DVB-S PL » Sat Feb 12, 2011 10:40 pm

Checked this and Czworka not use AC3, PID Audio is recognized as ISO/IEC 11172 (03 in SmartDVB PID editor), other channels from this frequency with the same way of audio transmitting are recorded correctly, so for now I've got no ideas about this, but try to investigate more ;)
DVB-S PL
 
Posts: 16
Joined: Sun Oct 18, 2009 4:30 pm
Location: Poland

Re: 0.2.1 beta test 2 install

Postby dahaka » Mon Feb 14, 2011 12:44 am

Czworka20110214-01_37_42.mpg

recorded 88 second with 37.8 MB ,using cyberlink 10 (video decoder) and ac3 filter (audio decoder).

XP sp3
Windows 10 1703 X64
Smart DVB 0.5.X.X
Tevii DVBS2-S662 - driver 5.1.9.2
driver 5.1.8.5(the best but not work @ windows 10)
dahaka
 
Posts: 10
Joined: Fri Jan 15, 2010 6:44 pm

Re: 0.2.1 beta test 2 install

Postby DVB-S PL » Mon Feb 14, 2011 4:07 am

Tried again now, but for me still failed :shock:

Win7 x64 Home Premium
Elecard MPEG2 Video Decoder 2.00.0.2525 or Microsoft DTV-DVD Video Decoder 6.1.7140.0 + Moonlight Odio Dekoda 1.00 with EVR or VMR9.

For me from Czworka I always get 4 bytes file, with HEX: 00 00 01 B9

Maybe this is OS related?
DVB-S PL
 
Posts: 16
Joined: Sun Oct 18, 2009 4:30 pm
Location: Poland

Re: 0.2.1 beta test 2 install

Postby SmartDVB » Mon Feb 14, 2011 11:01 am

ahh okay. You didn't mention if you were using the scheduler for this? There are some issues in the current beta when recording with guide names, do you have that option turned on perhaps? If so try turning it off to see if it resolves your issues...
SmartDVB
Site Admin
 
Posts: 616
Joined: Sun Feb 01, 2009 5:18 am

Re: 0.2.1 beta test 2 install

Postby DVB-S PL » Mon Feb 14, 2011 2:04 pm

No, I'm recording without sheduler, using button in toolbar. I tried to delete selection from EPG names & also for showing TS menu (not related, but to be sure).

However today I was able to do testing at x86 version of Win7 and there is no problem, so I assume that I've got problems with my SmartDVB installation (I'll try to reinstall) or this is x64 related issue (but why only on this channel, I have looked for any other channel with the same issue and I didn't find any).

I'll try to do further investigation about this ;)
DVB-S PL
 
Posts: 16
Joined: Sun Oct 18, 2009 4:30 pm
Location: Poland

Re: 0.2.1 beta test 2 install

Postby jim_dvb » Tue Feb 15, 2011 12:37 pm

I have just recorded a minute or so of Czworka (Hotbird 11642H), with no issues.
v0.2.1.0 Win7 64-bit
TBS QBox II with bda driver
jim_dvb
 
Posts: 4
Joined: Tue Feb 01, 2011 6:45 pm


Return to Beta Testing

Who is online

Users browsing this forum: No registered users and 1 guest

cron