Reloading channel on freeze occurring when rendering stream.

Here you can report any bugs/problems you encounter

Reloading channel on freeze occurring when rendering stream.

Postby Western_Hunter » Sun Jan 17, 2021 4:55 am

Out of nowhere when either turning pip or render on or off occasionally the stream will suddenly reload for absolutely no reason what so ever. This causes a sudden loss of picture and audio to occur within an other wise perfect stream capture. Signal is well above minimum lock. Is there anyway to recover the lost video and or audio within the period it takes to reload the stream or is it gone for good?

Windows 7 Ultimate 64 bit

TBS8922 bda.dev

Disabled time shift

v0.5.0.59
Western_Hunter
 
Posts: 0
Joined: Mon Jan 11, 2021 5:47 am

Re: Reloading channel on freeze occurring when rendering stream.

Postby SmartDVB » Fri Jan 22, 2021 12:37 pm

Out of nowhere when either turning pip or render on or off occasionally the stream will suddenly reload for absolutely no reason what so ever. This causes a sudden loss of picture and audio to occur within an other wise perfect stream capture. Signal is well above minimum lock. Is there anyway to recover the lost video and or audio within the period it takes to reload the stream or is it gone for good?


can you see some indication as to what might be happening in the SmartDVB.log logging file? Do you have any non default directshow options enabled (like 'reload graph on video freeze')?
SmartDVB
Site Admin
 
Posts: 616
Joined: Sun Feb 01, 2009 5:18 am

Re: Reloading channel on freeze occurring when rendering stream.

Postby Western_Hunter » Mon Jan 25, 2021 1:55 am

In Settings in Directshow the only box's that are ticked on are "Reload Video on freeze" and "Use VMR7 YUV Mixer (xp sp2+).

I've uploaded the full log here. https://drive.google.com/file/d/1OBbUn1irnGefPZh9zibT1OAH80KA4eI8/view?usp=sharing

I've noticed this in the logs at the bottom of the log.

"17:35:32 - [0039 02383 00043399]: >>> SIGNAL
17:35:33 - [0039 02384 00044413]: >>> SIGNAL
17:35:34 - [0039 02385 00045427]: >>> SIGNAL
17:35:35 - [0039 02386 00046441]: >>> SIGNAL
17:35:35 - [0039 02386 00046613]: CheckLNB: Detected LNB Default LNB(KU Circular) (ID: 8)
17:35:36 - [0039 02386 00046971]: []----->>>> [5695272,150994944]
17:35:36 - [0039 02387 00047455]: >>> SIGNAL
17:35:37 - [0039 02388 00048469]: >>> SIGNAL
17:35:37 - [0039 02388 00048703]: Removing filter 1001
17:35:37 - [0039 02388 00048703]: Removing filter 1002
17:35:37 - [0039 02388 00048703]: ClosePIP: Stopping graph
17:35:37 - [0039 02388 00048703]: Getstate ok
17:35:37 - [0039 02388 00048734]: Clearpesbuffers PIP
17:35:37 - [0039 02388 00048734]: Reset Stream Buffers
17:35:37 - [0039 02388 00048734]: Performing audio flush PIP
17:35:37 - [0039 02388 00048734]: Performing video flush PIP
17:35:37 - [0039 02388 00048765]: ReloadonvideoFreeze Checking Freeze Counter 1
17:35:38 - [0039 02389 00049483]: >>> SIGNAL
17:35:39 - [0039 02390 00050419]: LoadSatList : Loading lists...
17:35:39 - [0039 02390 00050419]: Starting loading channels
17:35:39 - [0039 02390 00050435]: Deleting items
17:35:39 - [0039 02390 00050435]: end deleting items
17:35:39 - [0039 02390 00050466]: stopping loading channels
17:35:39 - [0039 02390 00050497]: >>> SIGNAL
17:35:39 - [0039 02390 00050778]: LoadSatList : Loading lists...
17:35:39 - [0039 02390 00050778]: Starting loading channels
17:35:39 - [0039 02390 00050778]: Deleting items
17:35:39 - [0039 02390 00050778]: end deleting items
17:35:39 - [0039 02390 00050778]: stopping loading channels
17:35:40 - [0039 02391 00051090]: LoadSatList : Loading lists...
17:35:40 - [0039 02391 00051090]: Starting loading channels
17:35:40 - [0039 02391 00051090]: Deleting items
17:35:40 - [0039 02391 00051090]: end deleting items
17:35:40 - [0039 02391 00051090]: stopping loading channels
17:35:40 - [0039 02391 00051402]: LoadSatList : Loading lists...
17:35:40 - [0039 02391 00051402]: Starting loading channels
17:35:40 - [0039 02391 00051402]: Deleting items
17:35:40 - [0039 02391 00051402]: end deleting items
17:35:40 - [0039 02391 00051417]: stopping loading channels
17:35:40 - [0039 02391 00051449]: ReloadonvideoFreeze Checking Freeze Counter 2
17:35:40 - [0039 02391 00051449]: >>CStreamReader::RELOADING ON FREEZEFreeze timer reached 1200
17:35:40 - [0039 02391 00051449]: CMainFrame:: STOPPING SIGNALS!
17:35:40 - [0039 02391 00051449]: OnStreamReaderChangeChannelBegin:: STOPPING SIGNALS!
17:35:40 - [0039 02391 00051449]: CStreamReader::ChangeChannel CHANGECHANNEL ENTERED
17:35:40 - [0039 02391 00051449]: Changing channel, request count 1
17:35:40 - [0039 02391 00051449]: CHANGECHANNEL changing channel end
17:35:40 - [0039 02391 00051449]: CStreamReader::Freeze delay set to 0
17:35:40 - [0039 02391 00051449]: >>>>> Changing station to (noname) SID=1 101863302
17:35:40 - [0039 02391 00051449]: Setting new Audio/Video PIDs
17:35:40 - [0039 02391 00051449]: Stopping MediaControl 101863302
17:35:40 - [0039 02391 00051449]: Creating video renderer
17:35:40 - [0039 02391 00051449]: Renderer the same not recreating
17:35:40 - [0039 02391 00051449]: StopStream::Before getstate
17:35:40 - [0039 02391 00051449]: StopStream::After getstate
17:35:40 - [0039 02391 00051464]: CTSHandler::RESET
17:35:40 - [0039 02391 00051464]: After Streams Stopped 101863317
17:35:40 - [0039 02391 00051464]: Initializing new Audio/Video Stream (FTA Stream, H264, AC3:No, AAC:No)
17:35:40 - [0039 02391 00051464]: SetNewAV:: Waiting For AVTS
17:35:40 - [0039 02391 00051464]: CTSHandler:: AVTS PAUSED
17:35:40 - [0039 02391 00051464]: SetNewAV:: AVTS Wait Done 0
17:35:40 - [0039 02391 00051464]: CTSHandler:: AVTS PAUSED
17:35:40 - [0039 02391 00051464]: SetNewAV:: Resetting/clearing buffers
17:35:40 - [0039 02391 00051464]: SetNewAV:: Reset done
17:35:40 - [0039 02391 00051464]: SetNewAV:: Performing audio flush
17:35:40 - [0039 02391 00051464]: SetNewAV:: Deleting packets
17:35:40 - [0039 02391 00051464]: SetNewAV:: Performing video flush
17:35:40 - [0039 02391 00051464]: SetNewAV:: Done
17:35:40 - [0039 02391 00051464]: Clearing video headers
17:35:40 - [0039 02391 00051464]: Setting modulation 8PSK
17:35:40 - [0039 02391 00051464]: CMainFrame::OnVideoHeader
17:35:40 - [0039 02391 00051464]: GetLastSatId: Found previous satid 2608
17:35:40 - [0039 02391 00051464]: HandlePositioner: no positoner set
17:35:40 - [0039 02391 00051495]: DoDiseqc: no diseqc sent
17:35:40 - [0039 02391 00051495]: Gettickcount before settransponder 101863348
17:35:40 - [0039 02391 00051495]: DoChangeChannel:: Previous changechannel the same, not restarting http/trancoding to prevent HTTP stream breakup
17:35:40 - [0039 02391 00051495]: CStreamReader::SetTransponder TUNING (SETTRANSPONDER) FOR FREQUENCY 11893, SatID 2608 DEVICEID 0
17:35:40 - [0039 02391 00051495]: CStreamReader::SetTransponder Calling m_SetTransponderFunc
17:35:40 - [0039 02391 00051542]: LoadEITChannelFromQuery
17:35:40 - [0039 02391 00051542]: Finalize Eit Transaction count 0
17:35:40 - [0039 02391 00051558]: LoadSatList : Loading lists...
17:35:40 - [0039 02391 00051558]: Starting loading channels
17:35:40 - [0039 02391 00051573]: Deleting items
17:35:40 - [0039 02391 00051573]: end deleting items
17:35:40 - [0039 02391 00051573]: stopping loading channels
17:35:41 - [0039 02392 00052197]: LoadSatList : Loading lists...
17:35:41 - [0039 02392 00052213]: Starting loading channels
17:35:41 - [0039 02392 00052213]: Deleting items
17:35:41 - [0039 02392 00052213]: end deleting items
17:35:41 - [0039 02392 00052213]: stopping loading channels
17:35:41 - [0039 02392 00052229]: CStreamReader::SetTransponder SetTransponder Done
17:35:41 - [0039 02392 00052229]: SetTransponder OKAY TUNE SUCCEEDED
17:35:41 - [0039 02392 00052229]: CTSHandler:MDAPI Change channel SET
17:35:41 - [0039 02392 00052229]: Gettickcount after settransponder 101864082
17:35:41 - [0039 02392 00052229]: FULL TS SET
17:35:41 - [0039 02392 00052229]: Adding filter 8193
17:35:41 - [0039 02392 00052229]: Adding filter 4112
17:35:41 - [0039 02392 00052229]: Adding filter 512
17:35:41 - [0039 02392 00052229]: Before Rebuilding Graph 101864082
17:35:41 - [0039 02392 00052229]: ForceRebuild is true
17:35:41 - [0039 02392 00052229]: DoRebuildDirect::Stopping graph in rebuildavgraphdirect
17:35:41 - [0039 02392 00052229]: DoRebuildDirect::Getstate ok
17:35:41 - [0039 02392 00052229]: DoRebuildDirect::State was already stopped
17:35:41 - [0039 02392 00052229]: DoRebuildDirect::Stopping end
17:35:41 - [0039 02392 00052229]: CStreamReader:: RESET SKIPPED
17:35:41 - [0039 02392 00052229]: ENTERED REBUILDAVGRAPHDIRECT
17:35:41 - [0039 02392 00052244]: Getbufferspace pointers the same
17:35:41 - [0039 02392 00052244]: MDApiChangeChannel: VID_PID: 512, AUD_PID 4112
17:35:41 - [0039 02392 00052275]: Getbufferspace pointers the same
17:35:41 - [0039 02392 00052275]: MDAPI::CTA Paused
17:35:41 - [0039 02392 00052275]: []----->>>> [0,150994944]
17:35:41 - [0039 02392 00052275]: WRONG CONTINUITY CHECK cc=12, lastcc=2 (error count 0)
17:35:41 - [0039 02392 00052275]: SETTING NEW VIDEO START PTS 771401984
17:35:41 - [0039 02392 00052275]: SETTING NEW AUDIO START PTS 768139984
17:35:41 - [0039 02392 00052275]: In onaudioheaderread
17:35:41 - [0039 02392 00052275]: In onaudioheaderread end
17:35:41 - [0039 02392 00052275]: MDApiChangeChannel END: VID_PID: 512, AUD_PID 4112
17:35:41 - [0039 02392 00052275]: MDAPI::CTA Pause end (0, 0)
17:35:41 - [0039 02392 00052275]: Adding mdapifilter 2048
17:35:41 - [0039 02392 00052275]: Adding mdapifilter 1
17:35:41 - [0039 02392 00052275]: Rebuild: Audio Decoder Filter added
17:35:41 - [0039 02392 00052291]: Creating Video Decoder
17:35:41 - [0039 02392 00052291]: Using H264 video decoder ffdshow Video Decoder
17:35:41 - [0039 02392 00052291]: Connection Smart Filter to Video Decoder
17:35:41 - [0039 02392 00052291]: Rebuild: Connecting Video decoder to renderer
17:35:41 - [0039 02392 00052291]: Connecting Video Decoder to Renderer
17:35:41 - [0039 02392 00052322]: CTSHandler::ReadSPS::Sequence_parameter_set found at 7
17:35:41 - [0039 02392 00052322]: CTSHandler::Picture_parameter_set found at 52
17:35:41 - [0039 02392 00052322]: CTSHandler::H264 Processing found SPS/PPS
17:35:41 - [0039 02392 00052322]: CTSHandler::ProcessSPS length 40
17:35:41 - [0039 02392 00052322]: CTSHandler::ProcessSPS length after 40
17:35:41 - [0039 02392 00052322]: CTSHandler::ProcessSPS ProfileIDC 100
17:35:41 - [0039 02392 00052322]: PicWidthInMbs: 80
17:35:41 - [0039 02392 00052322]: PicHeightInMbs: 45
17:35:41 - [0039 02392 00052322]: FrameMbsOlnlyFlag not set
17:35:41 - [0039 02392 00052322]: AspectRatioIdc: 1
17:35:41 - [0039 02392 00052322]: process 3 sh264 1:1, iaspectratioidc 1
17:35:41 - [0039 02392 00052322]: dwLevel: 32
17:35:41 - [0039 02392 00052322]: Process sps done
17:35:41 - [0039 02392 00052322]: CS:In onvideoheaderread
17:35:41 - [0039 02392 00052322]: CStreamReader::OnVideoHeaderRead - Referring to end
17:35:41 - [0039 02392 00052353]: EXITED REBUILDAVGRAPHDIRECT
17:35:41 - [0039 02392 00052353]: After Rebuilding graph 101864206
17:35:41 - [0039 02392 00052353]: DoChangeChannel:: Starting MediaControl Run
17:35:41 - [0039 02392 00052369]: DoChangeChannel:: MediaControl Running
17:35:41 - [0039 02392 00052369]: DoChangeChannel:: Checking MDAPI
17:35:41 - [0039 02392 00052369]: CMainFrame::OnVideoHeader
17:35:41 - [0039 02392 00052369]: DoVideoAfterChangeChannel done
17:35:41 - [0039 02392 00052369]: CMainFrame::OnVideoHeader END
17:35:41 - [0039 02392 00052416]: Getbufferspace pointers the same
17:35:41 - [0039 02392 00052416]: Removing mdapifilter 2048
17:35:42 - [0039 02393 00053461]: >>> SIGNAL
17:35:42 - [0039 02393 00053726]: Removing mdapifilter 1
17:35:43 - [0039 02394 00054475]: >>> SIGNAL
17:35:44 - [0039 02395 00055489]: >>> SIGNAL
17:35:45 - [0039 02396 00056503]: >>> SIGNAL
17:35:46 - [0039 02397 00057299]: []----->>>> [4801896,150994944]
17:35:46 - [0039 02397 00057517]: >>> SIGNAL
17:35:47 - [0039 02398 00058531]: >>> SIGNAL
17:35:48 - [0039 02399 00059748]: >>> SIGNAL
17:35:49 - [0040 02400 00000762]: >>> SIGNAL
17:35:50 - [0040 02401 00001776]: >>> SIGNAL
17:35:51 - [0040 02402 00002306]: []----->>>> [4801896,150994944]
17:35:51 - [0040 02402 00002790]: >>> SIGNAL"
Western_Hunter
 
Posts: 0
Joined: Mon Jan 11, 2021 5:47 am

Re: Reloading channel on freeze occurring when rendering stream.

Postby SmartDVB » Tue Jan 26, 2021 11:23 am

ReloadonvideoFreeze Checking Freeze Counter 1


I'd disable the "Reload Video on freeze" freeze option if this does not work for you (or increase the intial delay if the freeze only occurs when switching channels). This option is somewhat experimental and relies on DirectShow so can be a hit and miss.
If you otherwise have no issues with the picture you can safely disable that option (by default it should be disabled)
SmartDVB
Site Admin
 
Posts: 616
Joined: Sun Feb 01, 2009 5:18 am

Re: Reloading channel on freeze occurring when rendering stream.

Postby Western_Hunter » Tue Jan 26, 2021 3:27 pm

SmartDVB wrote:
ReloadonvideoFreeze Checking Freeze Counter 1


I'd disable the "Reload Video on freeze" freeze option if this does not work for you (or increase the intial delay if the freeze only occurs when switching channels). This option is somewhat experimental and relies on DirectShow so can be a hit and miss.
If you otherwise have no issues with the picture you can safely disable that option (by default it should be disabled)

Aight thanks for clarifying. Hope you have a good one mate.
Western_Hunter
 
Posts: 0
Joined: Mon Jan 11, 2021 5:47 am

Re: Reloading channel on freeze occurring when rendering stream.

Postby Western_Hunter » Wed Jan 27, 2021 5:51 am

Western_Hunter wrote:
SmartDVB wrote:
ReloadonvideoFreeze Checking Freeze Counter 1


I'd disable the "Reload Video on freeze" freeze option if this does not work for you (or increase the intial delay if the freeze only occurs when switching channels). This option is somewhat experimental and relies on DirectShow so can be a hit and miss.
If you otherwise have no issues with the picture you can safely disable that option (by default it should be disabled)

Aight thanks for clarifying. Hope you have a good one mate.

I've ticked reload video on video freeze off but it keeps ticking itself on every time I close out and re-open SmartDVB.
Western_Hunter
 
Posts: 0
Joined: Mon Jan 11, 2021 5:47 am


Return to Bug Reports

Who is online

Users browsing this forum: No registered users and 1 guest

cron